Friday, May 28, 2010

New Gartner Magic Quadrant for Virtualization


Gartner recently released a new Magic Quadrant for Virtualization.  

As expected VMware is the clear leader with vSphere, both in terms of "Completness of vision" and "ability to execute".  Even more interesting is the placement of Microsoft and Citrix.  

Microsoft is the only company listed in the "challengers" quadrant.  Gartner doesn't place them very high in terms of "completeness of vision".  In my humble opinion, Microsoft does a great job of "just getting a product into the marketplace" and worries less about stability, features, etc..  However, they are Microsoft.  With the exception of Vista (which was just to horrible for anyone to use) they have the ability to push technology like no one else.  This allows them to rank high in terms of "ability to execute", and places them in the challengers quadrant and not Citrix.  

Citrix gets ranked in the "Visionary " quadrant, simply because XenServer is a much better solution than HyperV.  That being said, being a visionary isn't going to make you a leader. Nor will it necessarily make you money.

As for Oracle, RedHat, Novell, Solaris, and Parallels, they all get to share the "niche players" quadrant.  I rarely see these in my travels, but when I do it's because the fill a "niche".

I

Thanks to virtualization.info:
http://virtualization.info/en/news/2010/05/gartner-publishes-a-new-magic-quadrant-for-virtualization.html

VMware Workstation 7.01 Support for Linux Hosts

I just upgraded My copy of VMware Workstation to 7.01 and noticed a performance degradation over the previous version.  It's not enough to declare the VM unusable, or to impede my ability to get work done.  That being said, the performance hit is noticeable.

I am currently running Ubuntu 10.04 as my host OS and Windows 7 as a guest.  Ubuntu 10.04 is not listed as a supported host OS.  Last time I had an issue like this VMware Tools was having a problem access the hard drive causing excessive I/O.  That doesn't appear to be the problem here.  When I run "iotop" I don't see anything odd.