Tuesday, June 30, 2009

30 Days - Final Thoughts

Tonight ends my 30 days using a thin client laptop, so I guess it's time to share my final thoughts.

I had some challenges during these last 30 days, which I expected. As I worked to resolve them, I tried to employ solutions that I could recommend to a customer. Back doors and workarounds are something I could personally use, but any real solution would need to be something that an IT department could roll out and manage.

My biggest concern during this experiment was that my ability to connect to my virtual desktop was going to a challenge. I have to admit, I did have some challenges. Making some changes to our VPN configuration allowed me some options when faced with a customer network that was being "less than friendly". It didn't work 100% of the time. That's where a wireless broadband card would be helpful. I was unable to get my Blackberry to work with the X90 which was a disappointment. I was tempted to get myself a broadband card, but Apple just released a new iPhone, Palm released the Pre, and I'm still weighing my choices. From what I've read, I could use either access the Internet from my laptop. I really like the iPhone and all the apps that are available for it, but AT&T doesn't offer insurance. I usually drop my phone and need a replacement once a year. I can't afford the cost of a new or refurbished iPhone. I'm not sure which way to go. If I had one, it would have eliminated my connection issues. Having said that, once I modified my VPN, I had good success connecting where ever I was.

I also found that there were some applications that I just needed to have at a moments notice. I do a lot of presentations, but face to face and remotely. I had some issues using GoToMeeting over a VPN connection. I also had a presentation where I didn't have time to boot up and log into a virtual desktop. I needed to just start the presentation. My workaround was to install GoToMeeting and the Powerpoint Viewer directly on the X90. In a corporate setting, these could be pushed out using the Wyse Device Manager.

Flash proved to be a bit of a problem. I tried two different options, but neither worked as well as I hoped. The Wyse Flash Optimizer crashed my browser. This was because I had already upgraded IE to version 8. I have a lot of hope for this piece of software though. All of the other Wyse software worked great, and the Flash Optimizer is still beta. The other was the new Flash management options in View 3.1. These helped out, but only in IE and only when I had a decent connection. Firefox and Opera weren't helped out, and when I had a low bandwidth connection the flash content consumed a ton of bandwidth and slowed my whole VM down. I tried playing with the quality and bandwidth throttling options, but didn't find the right blend that would make the end user experience great. When I was connected to the same LAN as the virtual desktop, this was not an issue at all. Was this enough to make me unproductive? No.

One thing I'd like to see is the ability for the end user to control more of the options RDP offers. Using RDP (mstsc.exe) I can modify screen resolution, disable audio, and a few other options. This are handy when you have a slow connection. Being able to modify these would be helpful. Even if the user was presented with a choice of connection options that are pre-defined would be great.

I guess the real question it, will I keep using this? Yes and no. Typically I have Linux installed on my laptop, and I use VMware Workstation for an XP desktop. I'm definitely going to continue using my virtual desktop located at the corporate data center instead of using VMware Workstation. There is an open source VMware View client for Linux which I am looking forward to testing. I'm going to switch back to my Lenovo for a few reasons:
  • My Blackberry works with it, and I can connect to the Internet.
  • I can listen to music, this is big for me.
  • It's Linux based.
Having said that, I still plan on keeping the X90. It's great not having a heavy laptop to carry around. I would also recommend this to my customers for some use cases. On a LAN the experience was great. Remotely I had some issues, mostly with multimedia. However, many organizations block a lot of Internet sites that are not work related (YouTube, Facebook, etc..). They also shutdown audio services and sites. This eliminates most of the experience issues I was having.

I'm still going to continue to blog about mobile VDI. Once I'm using my Lenovo again, I'm going to test the open source View client and test this with my Blackberry.

Monday, June 29, 2009

Almost a week

It's hard to believe it's been almost a week since I've blogged last. I also can't believe it's been 29 days since I started this. It went pretty fast.

Not a lot has changed in the last week. Installing GoToMeeting on the X90 was the fix I needed. Once I did that, I've done a few GoToMeeting sessions since then. It would be nice to have this inside my virtual desktop, but I can live with the way things are now. In an enterprise deployment, GoToMeeting could be pushed to the clients.

Over the past week I also tested using iTunes to sync music on my iPod. I have a very large mp3 collection, so I didn't test my whole collection. I recently got my hands on some early Elvis Costello albums and wanted to add those to my iPod. Everything worked. No problems. I was on my home wireless when I did the test. It took longer than if I had used my laptop, but that's to be expected.

What about listening to mp3s? I tested this, I even went so far as to test listening to Pandora Radio. It worked in some situations. While at home there was a noticeable pause to the music when I changed windows. The pause is about a 1 second pause. This is because RDP needs to push a lot of new screen data to refresh the screen. When I'm at the office and not over the WAN this isn't an issue. If I were using a broadband wireless card this would eat away at my data plan. At times like right now, while I'm using a single Firefox window to write this blog post, Pandora works GREAT. If I were switching windows a lot, I would just grab my iPod.

Tomorrow is the final day of this experiment. I'm going to be sure to blog tomorrow night with my "final thoughts".

Tuesday, June 23, 2009

The Application I couldn't Live without.

So today I realized that I was going to have a challenge. I was going to be doing an executive presentation at a client's site today. I was going to have 15 minutes to do my presentation and get out. As I was thinking about this I realized that I wasn't going to have time to find an Internet connection if there wasn't one already in place. I needed to be able to get on, do my preso, and get out.

My first thought was that if I could get my Blackberry working with the X90 this wouldn't be a problem, but once I thought about it I realized that even if the Blackberry worked, I might not have a signal. That's when I realized that I needed Powerpoint ready to run, right on the X90.

My first choice was to use ThinApp and make a portable version that I could keep in a USB key. So I ThinApp'd Powerpoint, but think I did something wrong. I didn't want Powerpoint to be too large, so I selected ONLY Powerpoint during the MS Office install. No Word, Excel, or even "Shared Tools". After I finished ThinApp-ing Powerpoint I tested it to find that there were no spaces between the letters on the slides. The letters were just stacked on top of each other. Maybe someone else has seen this?

By then I was running out of time, so I installed the Powerpoint Viewer directly on the X90. This wasn't what I had wanted to do, but it worked perfectly, and for many organizations this might be better choice. Powerpoint Viewer is only good for doing the presentation, but you can't modify the presentation. This means you can do your preso, but have to do your "work" on your virtual desktop.

Either way, everything worked. The presentation looked perfect.

Monday, June 22, 2009

Mystery of the embedded quicktime video

I have an issue. When ever I hit a website that has an embedded quicktime video it locks up my web browser. Doesn't matter if it's IE, Firefox, or Opera. They all lock up.

Stolen Laptop

A friend of mine just had his laptop stolen. Like most people, it's been a long time since he's done a backup. If my X90 gets stolen, only the unit is gone. None of my data is lost.

Friday, June 19, 2009

GoToMeeting over VDI = FAIL

At least that's what the GoToMeeting support guy is telling me. I've had GoToMeeting working from my virtual desktop before. Not sure what's changed though. None the less, once he found out I was on a VM, he announced that was the problem. That my VPN connection to an RDP connection was forcing GoToMeeting to tunnel through my SSL connection.

It all sounds fishy to me. Especially since his own diagnostic tools said something else.

Thursday, June 18, 2009

Cruise Tonight

Tonight is my companies 2nd annual customer appreciation cruise. It takes off out of SF, circles Angel Island, our the Golden Gate Bridge and then back into SF. Last year was great, the weather was perfect!

Hopefully the weather gods will be with us tonight!

Wednesday, June 17, 2009

Upgraded View Today

I upgraded my VMware View environment today. It didn't take very long. 5 minutes to upgrade Composer on my vCenter server, 5 minutes to upgrade VDM, then 5 minutes to update the Agent in my VM.

Once this was done I started testing the flash quality and bandwidth throttling features. These are 2 very powerful features. The View Manager will allow you to set the quality of Flash media, and also throttle the amount of bandwidth it takes.

My first test was to set the flash quality to low, and set the bandwidth throttling to aggressive. I then went to VMware's website since I know they have flash content on their home page. My ThinApp'd copy of Firefox was brought it's knees. The page too forever to load, so I tried IE8. IE loaded the page with no issue. The flash quality was reduced as I expected, but not enough to make it look cheap. I did notice it was taking forever to load because of the throttling. So I increased that to moderate and the content loaded at a decent rate.

I then tried YouTube and was unable to get the content to load.

I then decided to test YouTube. YouTube's home page caused IE to stop responding. So I Googled for a video and tried to play it. No luck. So I increased the bandwidth throttling to conservative. No luck. Finally I disabled bandwidth throttling. No luck.

I'm concerned that this feature seems to help IE more than Firefox. I'm not sure if this is because I'm using a ThinApp'd version or not. I wasn't able to test this any further tonight.

Tuesday, June 16, 2009

So I still haven't gotten my Blackberry working with the X90 yet. Since June 10th I've used roughly 1.5 GB of of bandwidth. This includes all the time when I am at home connected to my home network. This makes me pretty comfortable with getting a new broadband wireless card. However, I think I'm gonna wait for some reviews on the new Palm Pre before I move on anything. I will be a happy man when I can use my cell phone as a modem.

While on a call with a customer today talking about VMware View the need to use local printers came up and I realized that I haven't played with ThinPrint yet. I also haven't had the chance to test printing to a local USB printer.

http://www.thinprint.com/

I'm also going to be a happy man when I can get the Wyse Flash Optimization to work without crashing IE8. Tonight while reading the View Admin guide for information on setting up ThinPrint I noticed a previously unnoticed section on Flash Quality settings. This isn't meant to optimize flash, but to reduce quality to improve performance. The reason I didn't notice this before is because it's for the latest version of View which I do not have installed in my lab yet. Maybe I can get this done quickly and test these new settings.

Monday, June 15, 2009

Visio Latency

I've had to work on a few large Visio diagrams over the past few days and I've noticed some latency in my mouse speed. Nothing that has really been noticeable until I started using Visio. It makes it hard to place a stencil at the right location on the drawing. This can be annoying when you are trying to line finish a drawing. Performance hasn't been bad enough to call it unusable though.

I have customers who've tested using CAD over RDP wtih no success. RDP just isn't fast enough.

Friday, June 12, 2009

VPN Success!

Yesterday I was able to get my VPN to connect over TCP port 80 from a client site! Connectivity has been my biggest issue, so this was a big step towards making sure I can connect to my virtual desktop.

Wednesday, June 10, 2009

Wireless Bandwidth Limits

Now that I've confirmed that AT&T, Verizon, and Sprint no longer offer unlimited data plans for their Broadband wireless cards (Sprint being the exception with their 4G network), I've decided to figure out if 5GB is enough for a serious connection. I downloaded AnalogX Netstat Live onto my X90. It will monitor my network bandwidth usage. So far, after 5 minutes of usage I am at 7.3MB. Please note, this is a BIG B, not a little b. We are talking in Bytes, not bits, since that data plans are rated in Bytes. (For those less geeky than I, that's an 8X difference.)

I'm now going to try to watch a movie on YouTube and see how much bandwidth that consumes....

OK. I only got 1/2 way through a video and the performance was so bad I had to stop. However, my bandwidth usage went from 7.5MB to 40.2MB.

I'm gonna let this tool run for a few days and calculate my bandwidth usage. It'll be interesting to see how much bandwidth I really use.

Just for fun, I've included an image from Sprint's site that explains what you can do with 5GB:



Speaking of bandwidth, I just ran my send backup using Avamar and it took less than a minute. Once this experiment is over, I'm going to re-test this with my Lenovo T500.

Blocked again.

I was blocked again my a customer firewall. When I get a moment this afternoon I'm going to install and try my friend Rob Daly's suggestion of using Hamachi. I'll use this as a "backdoor" so that I don't become stranded. However, I don't consider this a long term solution, nor is it a scalable solution for a company looking to roll this out.

I might also try VNC. The Wyse X90 has a VNC client installed by default. I just need to install the VNC server on my virtual desktop.

Tuesday, June 9, 2009

XP SP3

Today I haven't been around the computer much. My oldest is graduating middle school, and my 2nd oldest is graduating elementary school, so I've been tied up with school related activities.

In between events, I just installed SP 3 on my virtual desktop. This is a pre-requisite to installing the Wyse TCX Flash optimizer. Lately I've noticed that when I web browsing slows down my VM. I think this is related to flash content. So I'm going to get the TCX Flash optimizer installed and test it out.

Should have an update later.

Edit - No update to come. This version of the Flash Beta breaks IE8. Gonna find out if there is an IE8 compatible version.

Monday, June 8, 2009

Avamar - Take 2

I just looked that my first backup DID backup my D drive. 22 minutes for 7.3GB of data. That was Friday night. It's now Monday night. I'm going to backup again Wednesday night and see how much data there is, and how long it takes to back everything up.

Connection Issues

It happened again today. I was able to make a VPN connection while at a client site, but was unable to use it. Does anyone have any ideas why I'd be able to connect via VPN, but not use it? The traffic must be blocked by their firewall.

Once I was able to make a connection things ran fine.

I finally copied grpconv.exe from my Windows XP SP2 virtual desktop to the X90. It didn't give me any error when I tried running Blackberry Desktop installer, but still no usb modem. I even tried to manually install the drivers, no luck.

This is my biggest issue with Mobile VDI. Without access to my virtual desktop, I'm hosed. I was hoping to use my Blackberry as a life line when a faster connection wasn't available. I'm still working on this, but I'm afraid that this is just a limitation of using Windows XP embedded. I posted about this on the Blackberry support forums, hopefully someone else has seen this and has some ideas for me.

Connectivity is my biggest concern. Without it, I'm limited in what I can do. I'm tempted to get a Broadband card from Sprint with a "30 day guarantee" on it, and return it when I'm done here.

I also really want to test this out on a "slow" connection.

Friday, June 5, 2009

Day 5 - End of a long week

Sorry I didn't post this earlier, I go mountain biking on Friday nights in Angwin.

As I posted earlier, my VPN connection was blocked by another customer's firewall. I'm not really surprised by this. It just proves that I need to get my Blackberry running, however I wasn't able to do anything about that today. I had a lot to do today.

One thing I did do today was install Avamar on my virtual desktop. Avamar is a source based de-dup backup solution. Avamar will scan for new and modified files, break those files into variable length sub file segments, and then will back up only the unique segments. This means that if I open a Word document and change the work "him" to "her", only that block gets backed up, not the whole file. This means that the total amount of data that needs to be backed up is extremely small. It also means that the time it takes to do a backup is extremely short. Avamar also does global de-dup. For example, if I create a file and send a copy to 5 people, only 1 copy needs to get backed up by Avamar. When backup occurs on the other 4 systems, Avamar will identify that it has already backup that exact file, so no new backup is required.

I've started doing backups tonight. It only backed up my C drive. I need to change my backup settings, but it's getting late. It backed up and de-duped 7.3 GB of data in 22 minutes. I need to get my D drive backed up also. Will try that tomorrow.

This weekend I'm hoping to test the TCX flash optimizer. Before I do it I need to install SP3, so I want to take a snapshot in case things go wrong.

Blocked by another firewall

This morning another customer's firewall blocked me from accessing my VPN. Doesn't surprise me. Hopefully I'll get a chance to try the workaround that was suggested for getting my Blackberry working.

Thursday, June 4, 2009

Day 4 - Connectivity Issues

First thing this morning I received an email about the TCX Flash Optimization. The current beta is not supported on the X90 only because their hasn't been extensive testing on it, but there is no reason it won't work. I have yet to test this out though. Before I do that, I need to install XP SP 3 on my virtual desktop. Today was filled with other challenges.

The first challenge came when I got to a clients office at 1PM. They let me connect to their network and I quickly found out that their firewalls were blocking my VPN connection. They then offered me a DSL connection and I was able to connect to my corporate VPN. That's when things got strange. Although I was able to connect to the VPN, I wasn't able to access anything on my network. I couldn't RDP, SSH, or ping anything. Not sure what the issue was. Once on the VPN my packets shouldn't have been filtered by my clients firewalls (which they claimed didn't do outbound filtering anyway.)

Plan B was then to download and install my blackberry so that I could try to use that as a modem. So I downloaded the blackberry dekstop software but hit an issue. After 2 downloads, the file wasn't valid when I tried to run it. This has happened once before and I ignored it, but it seems that large file downloads choke on the X90.

So I had someone download it for me, and give it to me on a USB key. I was able to install the software, but found that the Blackberry USB Modem drivers didn't install. After a quick Google search I found instructions for manually installing the driver. However when I tried to install it I got an error stating that it couldn't find "grpconv". Google didn't turn up any info on where I could find this, nor how to work around this. Blackberry also didn't turn up any results on using their phone with XP embedded.

I really want to get this working. I'm very interested in testing USB file transfers over a slow connection.

On the upside though, I was able to host a GoToMeeting presentation from my VM this morning.

Defragmented Disk

Odd. I've had this VM 4 days not and it's already 58% defragmented. Not sure what that's about.

Gonna defrag.

Is there anything you want tested?

Does anyone have anything they would like to see tested? Let me know and I will try to test them.

Windows Search = FAIL

I started this project with a fresh install of Windows XP with only SP2 on it. So one of the first thing I did was run Windows Update to make sure I was properly patched. Due to shear laziness, I didn't inspect the "Optional" updates to closely and as a result wound up with Window Search 4.0 installed on my desktop. During Day 1 and 2 it didn't cause me any problems, so I didn't worry about it. However, tonight my virtual desktop started bogging down. It would pause for a few seconds, and then start to run again. So I opened task manager to do a little investigation and there they were. Those Windows Search processes and they were killing my performance.

My problems were solved the moment I saw this:



Has anyone had any luck with Windows Search 4?

Wednesday, June 3, 2009

TCX Flash Optimization - Beta

One of my friends at Wyse just got me a beta of their TCX Flash Optimization Beta!

I just downloaded the code and will test it out ASAP. I just have a few questions before I proceed. More to come.

Day 3 - Some interesting developments

First thing this morning my new 2GB flash drive arrived. After removing 7 screws, there was just 1 chip to remove and replace and I was done. XP embedded was already installed on it, so it was like having a brand new unit. To get started, all I had to do was install my Cisco VPN client. This took a total of 15 minutes. (It would have taken 10, but I had to re-download the VPN software.) Now, I have 1.5 GB of space on the X90.

I still need to re-attempt the installation of my Blackberry drivers and the Sprint SmartView software. I didn't have time today.

I faced a few new challenges today.

First was when the View Manager stopped responding. The View Manager is used connect my client to my VM. I could ping the View Manager and RDP into it, but my SSL connection was refused every time I tried to connect to my desktop. The View Manager is not required to maintain a connection to a desktop, but it is required to initiate the connection.

So what happens is the View Manager goes down? Ironically enough, a couple of my engineers were playing around in the lab with a solution to this very problem and were the cause of my problem. They had created a 2nd View Manager and were configuring one of our Cisco ACE load balancers to handle the front end traffic. In doing this, they disabled the SSL options for testing purposes.

Their idea, which I haven't been able to test yet, is that the ACE load balancer would balance the VDI work load between multiple View Managers. Users would be given the URL or IP address of the ACE to use as in the View Client. The ACE would then determine which of the View Managers to connect the user to. This could prove to be very useful when their are a lot of users trying to connect to simultaneaously. Once they realized I was down, they quickly re-enabled SSL for me and I was back and working again.

The second challenge, turned out to be less of a challenge than I had thought. The Wyse TCX Multimedia extension does a great job with AVI, WMV, and MPG movies, but not so well with flash media. I found this out when someone send me a link to a funny video on YouTube. The video performance was very choppy. I can live without YouTube for 30 days, but this is the time of year when I need to retake all of my EMC accreditations. I need to pass 4 tests, but to do that, I need to watch roughly 13 videos. Flash based videos. The nice thing is that these EMC videos are not very fancy, so any performance issues went unnoticed. I also realized after that fact, that I didn't reinstall my TCX extentions after changing out the flash drive. I'll be interested in seeing how much of a performance improvement I get when I get these installed again.

The third challenge came when it came to transfering files from my USB flash drive to my VM. The TCX USB Virtualizer allows me to plug a USB device into the X90 and have it appear as if I had attached it directly into my virtual desktop. I had a large folder full of files (roughly 600MB) that I needed to copy from a USB drive to my VM. This took around 15 minutes which isn't that bad considering that my Comcast Internet connection is only 1MB upload and the fact that I'm going through a VPN.

Tonight I'm going to re-install my TCX extensions and try to play some YouTube videos. I'm also going to see if I can find some options for optimizing my graphical performance.

Tuesday, June 2, 2009

Video Performance

So I tested out the TCX Multimedia extension for the X90 today. This enables you to get better video performance when trying to watch a movie. Since I'm not using a traditional laptop, I am only viewing the desktop using Microsoft's Remote Desktop Protocol (RDP). RDP wasn't designed for the demands of streaming video. Wyse's TCX software helps overcome this.

To test this, I downloaded a video file and played it. I have to admit, it was nearly perfect. Over the next couple of days I think I'll try to see if I get my hands on a movie and try watching that.

Day 2 and all is well

So while I was on my way to Sunnyvale this morning, I found out that my 10AM meeting was being canceled, and that my 3PM meeting was also canceled. All I had was a 1PM in the office in South San Francisco, so I got to spend a full day in the office which is odd.

Around noon today, it hit me that I was using VDI and didn't even notice it. I was connected to my VM, fixed some Visio diagrams, finished some documentation, and tried to get caught up on email.

Not too shabby...

Tomorrow I'm getting that flash drive, so we'll see how the upgrade goes.

Monday, June 1, 2009

Day 1 Woes....

Day 1 of my Mobile VDI was interesting to say the least.

The first thing that hit me, was that I didn't have the 300MB that I was expecting. With the latest version of XP embedded, the X90 only has around 100MB of drive space. For a lot of use cases, this would be fine, but since I needed to:
  • Install Blackberry drivers so that I could use my cell phone as a modem
  • Install the Sprint SmartView software
  • Install a Cisco VPN client

The 100MB wasn't close to enough space. The Sprint Software took 75MB alone! I also had trouble getting the Blackberry software to work correctly.

When I called a friend at Wyse, that's when I found out that 100MB was all I could expect with version of XPe. He did however tell me that they just released a 2GB flash drive for the X90. They've had a lot of users like me, who found that 100MB wasn't enough to become truly mobile. My friend pulled some strings, and in the next couple of days, I should receive a 2GB flash drive.

In the meantime, I decided to keep playing with what I have. So I tried to install the Blackberry drivers with little luck. It wouldn't see my 8703e as a modem, and the Blackberry Device Manager wouldn't let me modify the configuration. Luckily, today I was at a client site that had a wireless network that I could use.

I did have some success today though. I was able to install my Cisco VPN client, access my corporate network, and access my VDI desktop through the VMware View Client.

Speaking of installing applications, that took a little bit of investigation. When you start up the X90, it automatically logs you into a "user" account with little privileges. There is also a "Write Filter" that prevents changes to the X90 being permanent. Before you install application you need to log in as Administrator and disable the Write Filter. This allows you to install applications and customize the X90 for the User account.

Tonight I'm going to try to get all of my TCX extensions working (USB, Multimedia, & Rich Sound).

So what are my impressions of the X90 overall?

The 12.1" screen isn't as bad as I thought it would be. In fact, it's pretty nice! The screen is very bright and crisp. I have a 32bit color depth with a 1280X800 resolution.

The unit is also very light. The only real weight comes from the battery. I think it only weight 4lbs total.

Since there is no moving hard drive, there is no fan in the unit. This helps conserve battery life. The only drawback is that the hand rest seems to get a little hot.

I'll try to post an update tonight about how I'm doing with the TCX extensions.

Today it starts...

My Mobile VDI experiment starts today. I'm at a client site right now and haven't had a chance to do much until now. Once I booted the X90 up it was pretty much like I expected. It looks like an XP desktop. Once nice thing, is that it has the VMware VDI client already installed. I'll eventually need to try to upgrade that to the version that supports Offline VDI.

Right now I need to get download the manuals. By default, you are booted into a user account that has limited access. To install applications I'll need an Admin account.

So it's off the Wyse website to find that PDF!